Jump to content

Welcome to The Daily Neopets Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Chrome Adblock stopped working


  • Please log in to reply
10 replies to this topic

#1
Lady Lyuba

Lady Lyuba

    Princess Luna is on Team Moon.

  • FANTASTIC Members
  • 2,242 posts
  • Gender:Female
  • Location:Neovia
  • Interests:Ponies, Doctor Who, Loki, Star Trek, Tumblr, Neopets...am I leaving anything out?
  • Neopets Username: rissierose20
  • None
So, come New Year's Day, I got a virus. And, well, lots of traces of it still remain, such as I cannot get into Safari no matter what I do, I have to restart my computer when it's been on Sleep mode overnight, now I need to shut it down and turn it off. And, Adblock on Google Chrome, my usual browser, no longer works.


Anybody know how I can reinstall Adblock? I can't even get to the site that I installed it on, and when I click the Adblock in the upper right hand corner of my browser, it is blank save for lines. The virus FRIED my Adblock.

In fact it did the same for ALL my browsers! How do I get that to work again?

Order_S_zps8a003e0d.png

96740_mootix.gif


#2
Alice ☮

Alice ☮

    I like cheese

  • Super Members
  • PipPipPipPipPip
  • 642 posts
  • Gender:Female
  • Location:Canada
  • Neopets Username: alice_little
What type of computer are you on? (Mac or PC)?
Do you have FireFox? Maybe you could try downloading FF and re-installing adblock?
If not, maybe you could reinstall it in Chrome from here?

I also fried my adblock on Chrome a while ago. I tried synching my account with my gmail and ended up clearing all my extensions. Isn't life without adblock just awful? >_<
Posted Image

#3
Tynach

Tynach

    Cool Person

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Arizona, USA
  • Interests:Programming
    3D Modeling
    Computers
    Video Games
  • Neopets Username: tynach

I can't even get to the site that I installed it on


Two ideas about that: Your 'hosts' file may be corrupted/modified. Judging by the fact you're freaking about a virus, I'd say you're probably on Windows, so the Hosts file is located in C:\Windows\system32\drivers\etc\hosts

Edit that file with a text editor (Notepad, Notepad++, but NOT wordpad or Word), and make sure it only has lines that look similar to:

127.0.0.1	localhost loopback
::1		localhost

'127.0.0.1' is the IPv4 address of your computer for your computer. Basically, it uses that IP address to talk to itself. Trust me when I say your computer NEEDS to be able to do this. '::1' is the same thing, except for IPv6 - the new 'Internet Protocol' that they're rolling out that will allow for a higher number of IP addresses. Chances are you don't need this yet, but if it's already there, LEAVE IT. Don't necessarily put it in, though. The 'localhost' and 'loopback' and so forth, are needed because many programs (and the system itself) want to use, say, "localhost" as a way to talk to itself instead of saying '127.0.0.1' all the time.

Anything that deals with website URLs like 'google.com', or weird other IP addresses like 68.74.201.4, GET RID OF. Those should NOT be in your hosts file, unless you put them there yourself to redirect website addresses. That's what the 'hosts' file does - it creates aliases for websites to other websites - so you can redirect, say, 'microsoft.com' to 'ihatemycomputer.com'. Viruses will often do this to stealthily lead you to bad websites that look genuine, and even have the right name - you could be going to some person's fake antivirus program page, but it look and feel genuine.

If the hosts file is just fine, then you probably never got rid of the virus, and it's redirecting your web traffic in some other way. The only way to know for SURE is to do a fresh re-install of Windows, and sometimes that's necessary - but I'm sure that there are other tools and antivirus software programs you can try first.
Be sure to comment and give suggestions for my Roleplaying Website project! Any suggestions of any kind are welcome.

#4
billpika_x8

billpika_x8

    The Daily Neopets Zealot

  • Members
  • PipPipPip
  • 231 posts
  • Gender:Male
  • Location:Dela WHERE?
  • Interests:You can guess.
  • Neopets Username: billpika
I am guessing that the virus facilitates or guarantees delivery of advertising. :medieval: Time to fight back!
I've been on ever since I was 5. I had multiple accounts which I kind of trashed, and started anew in 2009. Wow. That was a long time ago.
Neopets...their forums are regulated like worst-case scenario communist countries.

And I love biscuits and kacheeks, but not biscuit kacheeks. Well, sort of. But not as much as I do starry kacheeks.

#5
Lady Lyuba

Lady Lyuba

    Princess Luna is on Team Moon.

  • FANTASTIC Members
  • 2,242 posts
  • Gender:Female
  • Location:Neovia
  • Interests:Ponies, Doctor Who, Loki, Star Trek, Tumblr, Neopets...am I leaving anything out?
  • Neopets Username: rissierose20
  • None
Sure I can't just re-install Adblock? Good to have some really computer-savvy people here, cos I certainly am not. Tynach, I'll probably need your help a lot.

Order_S_zps8a003e0d.png

96740_mootix.gif


#6
Guest_Yoshi__*

Guest_Yoshi__*
  • Guests

Sure I can't just re-install Adblock? Good to have some really computer-savvy people here, cos I certainly am not. Tynach, I'll probably need your help a lot.


I would check the hosts file first, if nothing unusual is there, then close it. NOTE if you are gonna edit it on Windows Vista or 7, you need to have administrative permissions. I wasn't able to change my own hosts file unless I ran Windows Explorer (explorer.exe) with administrative permissions.

If it is fine, then best bet would be to reinstall adblock or your browser cleanly.

#7
Tynach

Tynach

    Cool Person

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Arizona, USA
  • Interests:Programming
    3D Modeling
    Computers
    Video Games
  • Neopets Username: tynach

I would check the hosts file first, if nothing unusual is there, then close it. NOTE if you are gonna edit it on Windows Vista or 7, you need to have administrative permissions. I wasn't able to change my own hosts file unless I ran Windows Explorer (explorer.exe) with administrative permissions.

If it is fine, then best bet would be to reinstall adblock or your browser cleanly.


I keep forgetting Windows no longer makes you an admin by default (or maybe it does, but not on OEM systems). But yes, definitely check your hosts file first.

Sure I can't just re-install Adblock? Good to have some really computer-savvy people here, cos I certainly am not. Tynach, I'll probably need your help a lot.


Well, if it isn't letting you go to the website you installed Adblock on at all, then something else is going on, which needs to be fixed first. That's why I suggested you look at your hosts file.
Be sure to comment and give suggestions for my Roleplaying Website project! Any suggestions of any kind are welcome.

#8
Guest_Yoshi__*

Guest_Yoshi__*
  • Guests

I keep forgetting Windows no longer makes you an admin by default (or maybe it does, but not on OEM systems). But yes, definitely check your hosts file first.

Yea even with an administrator account, you need to authenticate, especially if UAC is enabled. Everytime I want to edit a system file, I end the explorer.exe process and start a new run as admin process explorer.exe (Process Explorer from sysinternals makes it pretty easy XD) This is unless its Windows XP or earlier or UAC is disabled like most have it as.

-------------------
(This is just an idea, doesn't mean it actually happened we will try to check out other solutions)

Also there is a chance the virus may have altered some critical system files or put some damage to your computer, I assume it is damaged slightly?

You can try restoring from a backup if all else fails, if you do not have a backup made, go to start > run (or windows key and R) and type rstrui.exe. UAC will come up if its enabled unless its Windows XP or earlier. If you have XP or earlier, Open up System Restore in the Administrative Tools folder. Unless of course, you disabled it.

If that does not work and our help isn't really doing anything, you can reinstall the OS but that might be a bit overkill.



What type of computer are you on? (Mac or PC)?
Do you have FireFox? Maybe you could try downloading FF and re-installing adblock?
If not, maybe you could reinstall it in Chrome from here?

I also fried my adblock on Chrome a while ago. I tried synching my account with my gmail and ended up clearing all my extensions. Isn't life without adblock just awful? >_<


I don't have adblock installed and it doesn't really effect me in any way.

#9
Tynach

Tynach

    Cool Person

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Arizona, USA
  • Interests:Programming
    3D Modeling
    Computers
    Video Games
  • Neopets Username: tynach
<troll amount="slight">
Wipe the drive and install Linux!
</troll>
Be sure to comment and give suggestions for my Roleplaying Website project! Any suggestions of any kind are welcome.

#10
Lady Lyuba

Lady Lyuba

    Princess Luna is on Team Moon.

  • FANTASTIC Members
  • 2,242 posts
  • Gender:Female
  • Location:Neovia
  • Interests:Ponies, Doctor Who, Loki, Star Trek, Tumblr, Neopets...am I leaving anything out?
  • Neopets Username: rissierose20
  • None
Somehow the Adblock re-installed itself all on its own! I have no idea how it did that, it's really weird. No, I didn't do anything. If my computer is posessed, it is possessed in a good way! Really, REALLY odd, but good!

Order_S_zps8a003e0d.png

96740_mootix.gif


#11
Guest_Yoshi__*

Guest_Yoshi__*
  • Guests
or it auto updated to the new version......




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users